Te encuentras en la tarea de actualizar tu version de mysql y al hacerlo luego intentar reiniciar mysql tienes el siguiente error..

/usr/libexec/mysqld: Table ‘mysql.plugin’ doesn’t exist

Bueno el comando mysql_upgrade sirve para examinar todas las tablas de todas las bases de datos para buscar incompatibilidades con la versión actual de mysql que estes usando. Sin embargo es muy posible que al ejecutar el comando te encuentres con algunos problemas como el antes descrito, bueno ese problema lo mas común es que tengas una configuraación obsoleta en tu archivo my.cnf.

Para solucionar el problema basta seguir estos pequeños pasos:

Respalda el actual archivo my.cnf

cp /etc/my.cnf /etc/my.cnf_backup

Creamos uno nuevo a partir del my.cnf.rpmnew

cp /etc/my.cnf.rpmnew /etc/my.cnf

Reinicia mysql

/etc/init.d/mysqld start

La causa del problema se debe a que en la version 5.0 de MySQL existía una variable llamada “skip-bdb” la cual fue eliminada en MySQL 5.1, una solución rápida sería comentar la línea donde esta esta variable.

Luego puedes ejecutar el comando mysql_upgrade para corregir errores en las bases de datos y se ajusten a la actualización.

MFCP!!!