En versiones antiguas de Joomla (al menos 1.5.8) con PHP 5.3 se produce un error con el módulo de Menus modMainMenuHelper:

Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference

La mejor opción en este caso es actualizar el joomla es evidente que tiene un problema con el php, sin embargo si no podemos actualziar el joomla, podemos usar la siguiente alternativa.

Modificamos la llamada por referencia de la funcion buildXML()

$ vi /modules/mod_mainmenu/helper.php

Buscamos la siguiente línea:

function buildXML(&$params)

Y la reemplazamos por esta:

function buildXML($params)

Ahora bien, es posible que al modificar esta línea tengamos errores al ingresar al administrator, asi que debemos modificar también.

$ vi /libraries/joomla/html/html/grid.php

Y cambiamos las siguientes líneas:

function access( &$row, $i, $archived = NULL )
function checkedOut( &$row, $i, $identifier = ‘id’ )

Por las siguientes:

function access( $row, $i, $archived = NULL )
function checkedOut( $row, $i, $identifier = ‘id’ )

Esto es solo una solución temporal, asi que como indico al inicio, es menester actualizar el joomla, no solo por corregir el error sino también por seguridad, recuerden que joomla es muy vulnerable por lo que para evitar problemas es menester mantenerlo actualizado.

MFCP!!!